Télécharger une image

Droppez une image ou
Créer un compte Login

Quitter

after|help

@after - Vu il y a 3 ans

Partage public

Gérer les options de partage de ce post.

Activer le partage

Partage : désactivé


14
aot 2014

Bugs et maintenance

Il y a 4 ans, 427 mots

Par after|help
Une liste de bugs, et l'état d'avancement de leur correction.

Général


- Marquer tout comme lu a l'air de flagger les PJ (compte faux)
- Mettre un timer de 12h sur les like / dislike + follow
- COORS quand on est dans un subdomain : Image from origin 'after.io' has been blocked from loading by Cross-Origin Resource Sharing policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'pad.after.io' is therefore not allowed access.
- Compte des commentaires est buggé
- No cache ajax sur le compte des notifications
- Recherche tape dans le contenu deleted ?
- Url rewrite est sale
- No cache sur getUnreadCount()
- Logs follower (xxx vous suit) à l'air de déconner
⇣ - Dimensions minimales / responsive
- Compte like/unlike de ses propres coms n'est pas affiché
- Changement de skin rafraichit plus le profil perso (-skin au lieu de -theme)

Commentaires


- Auteur d'un contenu non averti en cas de subComment

Archives


⇣ - Page d'archive freeze

Contenu


- Back to top marche pas sous Firefox
- Bouton de filtre des listes a un problème de padding sous Firefox
- Mention like/unlike d'un com supprimé reste dans les logs
- Accents dans la recherche
- Erreur d'index dans les listes au lazy loading

Poster / éditer


- Editer un post pièce jointe remet son parentId à 0
⇣ - Impossible de faire un lien interne (curl n'a pas de session)
- Poster un lien dans l'éditeur a besoin de // pour ne pas faire un lien relatif
- Modifier un contenu perso le publie (state = hidden doit être modifié au passage)
- Publication blog : images attachées déconnent
- Remoulage commentaires
- Like et/ou unlike ?
- Barre d'actions merdoie sur les petites résolutions
- Envoyer une galerie dans un post merde pas mal

Minichat


⇣ - Mode micro génère des warnings dans les pages normales (undefined membreData ligne 111 de chat.php)
- Mode micro génère une erreur JS en édition (resizeAllKendo is not defined)
- Compteur de lignes du chat est bizarre (cache ajax)
- Nocache sur l'appel Ajax du MC
⇣ - Compteur d'activité quotidienne à l'air à côté de la plaque
Tous les articles de after|help

Taggé dans :

#after|bug

Discuter ()


Chère équipe technique,
Vous devez déjà être au courant et pas avoir envie de corriger ça, mais l'url rewrite a l'air un peu peaufinable, genre par exemple ça

after.io/lire/3[...]n-bonus-la.html

(Le "à" qui gicle, l'apostrophe qui passe en numérique, les liens qiu passent en url, toussa).

Amour.
Il y a 4 ans 0 0

Zib
Ouais c'est sale, il va me falloir un leet du regexp. En même temps vu qu'aucune page n'est publique, y'a pas trop d'enjeu au niveau SEO :)
Il y a 4 ans 0 0

Zib
Yabon (j'avais oublié le setlocale en francais, du coup iconv faisait n'importe quoi)
Il y a 4 ans 0 0

Le compteur de commentaires ne se décrémente pas à la suppression d'un commentaire (cf. par exemple le blog "mitose V4"). Du coup, bah hein, forcément.
Il y a 4 ans 0 0

En fait si, ça fonctionne très bien, t'as dû tester sur ce blog et pas remettre le compteur au bon niveau, peut-être.
Il y a 4 ans 0 0

Zib
Oui je sais pas ce que j'ai fait, mais ca fonctionne sans fonctionner, faut que je reteste le compte des commentaires...
Il y a 4 ans 0 0

Pas à proprement parler un "bug", mais sous les posts, l'échelle des Likes&Favs, ce serait peut-être plus pertinent que ce soit des entiers ?
Et du coup je pense qu'il va falloir réfléchir aussi à quelque chose de plus pertinent niveau du temps: quand un post arrive, avalanche de fav/like (ou pas) dans les premiers jours.... mais alors très rapidement les vieux posts vont avoir un graph"naze": un niveau ridiculement continu et on verra bien péniblement les éventuelles variations du début... ça demande un peu de réflexion j'imagine (enfin peut-être pour décider "c'est trop chiant on laisse").
Il y a 4 ans 0 0

Sur les pages de Profil, en bas de la liste des posts, y'a encore un "une page au hasard ?" qui renvoie vers 404.
Il y a 4 ans 0 0

Quand je dis "liste des posts", il y a erreur, je parle de la liste des images et vidéos, qui affiche ce titre également (ce qui fait sens, mais je viens de me rendre compte que le bouton d'à côté s'intitulait pareil).
Il y a 4 ans 0 0

Alors celui là je vois pas trop ou il est, tu as une adresse ?
Il y a 4 ans 0 0

C'était after.after.io/liste/pic , mais écoute... bah on dirait que ça s'est réglé "tout seul" depuis ....je vais aller boire de l'eau.
Il y a 4 ans 0 0

Il manque je pense un filtre sur les types de fichiers dans les lightbox d'upload d'image. On peut apparemment uploader ce qu'on veut présentement.
Il y a 4 ans 0 0

Zib
La tu m'inquiètes :) Normalement c'est géré, de façon assez laide certes (une sale alerte), mais néanmoins efficace.
Il y a 4 ans 0 0

Y'a des sorties intempestives du mode large (maj W), la seule que je répète clairement c'est quand je vais sur un profil.
EDIT: en fait l'état de l'affichage larg/pas large a l'air propre (et reste mémorisé) à chaque page de profil.
Il y a 4 ans 0 0

Sur la page de profil, concernant le tableau de bord (je parle de la ligne avec tous les compteurs), eh bien le cadre de fond, il ne suit pas le contenu (si on a une petite fenêtre, ça passe sur 2 lignes, et le cadre reste sur une seule ligne, ce qui est fort laid).
Il y a 4 ans 0 0

Bien entendu c'est la même chose avec la barre des likes/fav en dessous des posts
Il y a 4 ans 0 0

C'est effectivement un problème qui ne concerne que les petites fenêtres, et donc sans doute les petits écrans.
Il y a 4 ans 0 0

Zib
Me suis pas encore occupé des écrans de merde petites résolutions, faudra effectivement coller des largeurs mini par ci par la.
Il y a 4 ans 0 0

Les logs de aimé/pas aimé d'un commentaire supprimé restent dans la liste des logs.
Il y a 4 ans 0 0

Zib
DIABLERIE.
Il y a 4 ans 0 0

Comme pendant longtemps dans la V4, le retour à la page précédente ne met pas à jour les commentaires récents.
Il y a 4 ans 0 0

Zib
Et ca c'est bien normal (cache, tout ca). Je peux désactiver le cache, mais ca serait super contre productif, surtout vue la masse d'images qui se baladent partout.
Il y a 4 ans 0 0

Et un cache plus subtil à base de Last-Modified/If-Modified-Since au lieu Cache-Control:max-age, ça serait pas gérable ?
Il y a 4 ans 0 0

Zib
C'est potentiellement fixax, à tester.
Il y a 4 ans 1 0

J'ai l'impression que ça marche ma foi :)
Il y a 4 ans 0 0

Pas sur que ce soit considéré comme un bug mais si on change de pseudo sur le site il est toujours nécessaire de se logger avec le premier pseudo créé.
Il y a 4 ans 0 0

Oui, parce que le "premier pseudo" est en fait le nom de ton compte, ce qui n'est pas la même chose que ton pseudo, en fait.
Il y a 4 ans 0 0

Je m'endoutais vaguement
Il y a 4 ans 0 0

La bulle d'activité minichat se pointe également sur petits avatars des logs de la page de profil (vu par moi ou quelqu'un d'autre)
Il y a 4 ans 0 0

Zib
Et c'est SUPER COOL.
Il y a 4 ans 0 0

Je sais pas si ça ce qualifie comme un bug, mais sur des images de cadre trop claires, les menus de gauche (dont le texte est blanc) sont illisibles. Cf. imgur.com/thmed4v (ou ma page, mais elle peut changer : x.after.io/)
Il y a 4 ans 0 0

Zib
Ne pas mettre d'image blanche sous un texte blanc est une solution qui a donné de bons résultats. Sinon y'a sans doute moyen soit de tenter de deviner sombre ou clair à la lecture de l'image soit de rajouter l'option boutons noirs / boutons blancs quelque part...
Il y a 4 ans 0 0

Ouais, je pensais à un truc du genre de l'option des couleurs, en fait. Ou alors un truc du genre de ce qu'il y a dans la colonne de droite (un fond plus gris foncé, mais transparent quand même).

Après, c'est juste histoire de pas limiter notre créativité en bannissant le blanc, si tu te sens une âme de tyran de l'expression artistique, libre à toi de ne rien faire.
Il y a 4 ans 0 0

Zib
C'est en place, à l'essai :) Les futures images postées sont testées pour choper leur luminosité globale, et si elle est élevée le texte passe en noir, cf. le thème "gros noeuil" after.io/themes
Faudra ajuster la limite de ce qui est considéré comme "trop clair" au fur et à mesure.
Il y a 4 ans 0 0

Nice, ça passe effectivement en noir. Après, mon image a trop de motif donc ça reste illisible, mais bon c'est un autre problème.
Il y a 4 ans 0 0

La recherche n'aime pas les accents :

after.io/recherche/s-b-p/theme => des résultats
after.io/recher[...]-b-p/th%C3%A8me => rien
Il y a 4 ans 0 0

Zib
Fixax!
Il y a 4 ans 0 0

En ce qui concerne les posts (de blog d'article long), enfin ailleurs je ne suis pas allé voir, les liens dans le texte ne s'ouvrent pas dans un autre onglet, et donc on quitte ce somptueux site, et c'est bien dommage.
Il y a 4 ans 0 0

Quand j'essaie de modifier after.io/lire/947/ il n'a rien dans le champ "URL de la video".

Il y a peut-etre également un soucis avec la gestion des flags, j'avais mis "chat" et "mignon" pendant l'édition (ils apparaissaient avec la croix pour les supprimer pendant l'édition, donc j'ai bien du appuyer sur entrée) mais seul "chat" apparait sur la page de la vidéo dans "à voir" et pareil quand je vais pour l'éditer. Je ne me souviens pas avoir fait une manip spécifique dans l'ordre d'ajout des tags ou de la vidéo.
Il y a 4 ans 0 0

Je confirme. Lorsqu'on modifie une vidéo, le champ URL est vide. Du coup, on se retrouve avec une belle image grise lorsqu'on valide un peu trop vite.
Il y a 4 ans 0 0

Un bouton "marquer tout comme lu" général dans la colonne de gauche ce serait pas mal
Il y a 4 ans 0 0

Alors j'ai un bug rigolo de scroll infini. Sur la page des posts after.io/liste/blog, j'ai 2 posts non lus (« O&C Duels » & « La salle du Roi de la Montagne »).

Si je filtre la liste pour n'afficher que les non lus, le deuxième post apparaît en double au chargement de la page. Et après, quand je scrolle, le deuxième post se duplique à l'infini. Ça marche en affichage liste comme en aperçu complet.

Si ça peut aider, ça appelle cette url : after.io/ajax/getContenu.php&owner=all&favorite=no&unread=yes&previousContenuId=2014-09-18+20%3A59%3A00&tags=&_=1411374599985
Il y a 4 ans 0 0

Zib
Hm ui ce previousContenuId m'a l'air bien foireux, je vais regarder merci :)
Il y a 4 ans 0 0

Zib
Ca le fait toujours ?
Il y a 4 ans 0 0

Oui, ça répète toujours, l'url appelée en xhr, c'est after.io/ajax/getContenu.php&owner=all&favorite=no&unread=yes&previousContenuId=2014-09-18+20%3A59%3A00&tags=&privateMode=no&sortBy=&_=1412496299554 (soit vaguement la même chose qu'avant)
Il y a 4 ans 0 0

Les tags ajoutés à une vidéo n'ont pas été enregistrés (Opera 28).
Il y a 4 ans 0 0

Fausse alerte. Le problème a eu lieu suite à plantage de Firefox. La navigation était gelée sur le message de confirmation d'enregistrement du post. J'ai dû forcer l'arrêt de Firefox.
Il y a 4 ans 0 0

Quand on veut par exemple voir qui a aimé un post, les étiquettes de nom en survol des avatars sortent pas de la case (enfin surtout pour le premier tout à gauche), et c'est pas JOLI JOLI.
Il y a 3 ans 0 0

lignes de chat